Ticket Submission Unavailable for Unauthenticated Users

Incident Report for CoinTracker

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 15:27 UTC

Investigating

CoinTrackers are not able to submit a support ticket from the web application. Tickets can be submitted by navigating to Chatoshi from the help center or emailing support@cointracker.com.
Posted Aug 04, 2025 - 14:22 UTC
This incident affected: Web (Website).