Android users may experience an “Oops! Something went wrong on our end” error when using the CoinTracker app.

Incident Report for CoinTracker

Resolved

This issue has been resolved in the newly released version 2.5.2.

Android users who already have the app downloaded and are not able to load the app will need to update to that version. iOS users are not impacted.
Posted Dec 17, 2025 - 03:24 UTC

Investigating

We are currently investigating this issue.
Posted Dec 15, 2025 - 16:55 UTC
This incident affected: Web (Website).