Bitcoin wallets failing to sync.

Incident Report for CoinTracker

Monitoring

This sync issue has been resolved and we are monitoring the results.
Posted May 03, 2026 - 07:31 UTC

Investigating

We are currently investigating this issue.
Posted May 02, 2026 - 21:04 UTC
This incident affects: Web (Website).