Tax Forms are not downloading

Incident Report for CoinTracker

Resolved

This incident has been resolved.
Posted Apr 24, 2024 - 23:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2024 - 23:11 UTC

Identified

We have identified the issue and are deploying a fix.
Posted Apr 24, 2024 - 23:00 UTC

Investigating

We are currently investigating an issue where users are unable to download their tax reports. Users will continue to receive their tax reports via email while we are working to resolve this issue. Thank you for your patience while we investigate!
Posted Apr 24, 2024 - 22:24 UTC