Incorrect portfolio balances displayed on website and mobile app

Incident Report for CoinTracker

Resolved

This incident has been resolved.
Posted Mar 13, 2024 - 21:38 UTC

Update

We are continuing to investigate this issue.
Posted Mar 13, 2024 - 21:35 UTC

Investigating

We are investigating an issue with incorrect portfolio balances displayed for some users. We will update this status page as things return to normal. Thank you for your patience!
Posted Mar 12, 2024 - 16:05 UTC
This incident affected: Web (Website).