Tax report latency
Incident Report for CoinTracker
Resolved
This incident has now been resolved. We are experiencing higher than expected traffic during tax season, please reach out to CoinTracker support if you have any questions.
Posted Apr 14, 2022 - 16:11 UTC
Monitoring
Tax report latency has been reduced to several minutes, delivery should be processed more quickly. We will update this status once delivery time is back to normal.
Posted Apr 14, 2022 - 15:31 UTC
Investigating
There is a 3.5 hour delay when generating tax forms from when users requested in the Tax Center, our engineering team is investigating.
Posted Apr 13, 2022 - 21:32 UTC
This incident affected: Web (Website).