Ethereum syncs not working

Incident Report for CoinTracker

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 15:04 UTC

Investigating

We are currently investigating an issue with Ethereum wallets not syncing.
Posted Apr 09, 2026 - 14:37 UTC
This incident affected: Web (Website).