Unable to download 2025 tax forms

Incident Report for CoinTracker

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 15:43 UTC

Investigating

Users are temporarily unable to download 2025 tax forms. We are working on resolving this issue as soon as possible.
Posted Apr 16, 2026 - 14:42 UTC
This incident affected: Web (Website).