Transactions page does not load

Incident Report for CoinTracker

Resolved

The issue has been resolved and the transactions page should load normally now. We appreciate your patience while we worked to resolve this!
Posted May 09, 2024 - 19:17 UTC

Investigating

We are currently investigating an issue where the transactions page will not load, and shows an error: "Oops! This is unexpected"

We will update this status page as we have more information - thank you for your patience!
Posted May 09, 2024 - 18:23 UTC
This incident affected: Web (Website).