Tax forms failing to email

Incident Report for CoinTracker

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 14:13 UTC

Investigating

We noticed a spike in failed tax form email deliveries. We are actively monitoring the situation.

Your forms should still download as expected as long as you remain on the page.
Posted Mar 14, 2025 - 17:00 UTC
This incident affected: Web (Website).