Portfolio page not loading for some users

Incident Report for CoinTracker

Monitoring

A fix has been implemented and we are monitoring results.
Posted May 27, 2026 - 17:59 UTC

Investigating

We're aware that some users are experiencing issues loading their Portfolio page. Other areas of CoinTracker are not affected. We're investigating and will provide updates here as we learn more.
Posted May 27, 2026 - 14:05 UTC
This incident affects: Web (Website).